Reply To: OpenCore

Home Forums Macs Desktops Mac Pro OpenCore Reply To: OpenCore

  • artem
    Participant
    #1415626

    Hi, thanks for posting this — I have got as far as step 3 fine — the EFI is working, I get the boot screen. Going to System Preferences/Software Update I only get the option to upgrade to Monterey. What is the procedure to upgrade to Catalina form this point? I have tried downloading the full installer and that doesn’t work (I get the message “This version of macOS 10.15 cannot be installed on this computer”.

    Thanks for your help, Chris

    System: MacPro 5,1 mid2010. 2 x 3.46GHz OSX 10.14.6  Radeon RX590 GPU

    Hi Chris,

    Can you try with Big Sur just to check? The message that you receive points to compatibility with the machine which would indicate Open Core not working.

    Link for macOS’s https://support.apple.com/en-gb/HT211683

     

    Hi Matty,

    When I try to download the OS from that page, I get taken to the AppStore, then clicking on ‘GET’ opens up System Preferences > Software Update. There, after a brief ‘Finding Update’ moment, I get the error message “Update not found: The requested version of macOS is not available”. Is that because it’s no longer available on the app store, or because of the machine incompatibility? If, as you suggest, OpenCore may not be working, how can I check that? I do get the new boot options.

    I tried re-c0pying the EFI files, and when I opened OpenCore Configurator again, I noticed that it said “You seem to have an old version of OpenCore bootLoader: This app creates a configuration file for version 0.7.5”.

    Many thanks for your help!

    Chris

    Hi matty, I followed all the steps and ran into the exact same issue described above. Running a dual-socket Mac with the following hardware:
    <p class=”p1″>Hardware Overview:</p>
    <p class=”p1″>  Model Name: Mac Pro</p>
    <p class=”p1″>  Model Identifier: MacPro5,1</p>
    <p class=”p1″>  Processor Name: 6-Core Intel Xeon</p>
    <p class=”p1″>  Processor Speed: 3.46 GHz</p>
    <p class=”p1″>  Number of Processors: 2</p>
    <p class=”p1″>  Total Number of Cores: 12</p>
    <p class=”p1″>  L2 Cache (per Core): 256 KB</p>
    <p class=”p1″>  L3 Cache (per Processor): 12 MB</p>
    <p class=”p1″>  Hyper-Threading Technology: Enabled</p>
    <p class=”p1″>  Memory: 96 GB</p>
    <p class=”p1″>  Boot ROM Version: 9144.0.7.3.1</p>
    <p class=”p1″>  SMC Version (system): 1.39f11</p>
    <p class=”p1″>  SMC Version (processor tray): 1.39f11</p>

    <p class=”p1″>Radeon RX 580:</p>
    <p class=”p1″>  Chipset Model: Radeon RX 580</p>
    <p class=”p1″>  Type: GPU</p>
    <p class=”p1″>  Bus: PCIe</p>
    <p class=”p1″>  Slot: Slot-1</p>
    <p class=”p1″>  PCIe Lane Width: x16</p>
    <p class=”p1″>  VRAM (Total): 8 GB</p>
    <p class=”p1″>  Vendor: AMD (0x1002)</p>
    <p class=”p1″>  Device ID: 0x67df</p>
    <p class=”p1″>  Revision ID: 0x00e7</p>
    <p class=”p1″>  Metal: Supported, feature set macOS GPUFamily2 v1</p>
     

    I worked around the unavailable update from Catalina by downloading the installation from another machine running Catalina. Whenever I’m trying to install it though I’m getting ‘This version of MacOS 10.15.7 cannot be installed on this computer’.

     

    I never messed with any dosdude/opencore packages before and the Mac had been upgraded to Mojave using official update from Apple. Any ideas?